Installing wireless VT6655 on roboard

by

The installation of the wireless card in the roboard is as in the following 5 steps.

(1)  Getting the needed tools

Beside the packages to the linux, we might use usefull tools like putty, a ssh terminal to access the roboard if you know the IP and WinSCP to access the roboard folders as an easy way to manage and drag and drop files or folders, from windows environment.

Getting the linux tools

Get the bzip2 # apt-get install bzip2

Get the make # apt-get install bzip2

Get the gcc # apt-get install gcc

Get the unrar #apt-get install unrar-free

Get the wireless-tools # apt-get istall wireless-tools

Get the wpa supplicant # apt-get install wpasupplicant

(2) Installing the compatible version of linux

To install the wireless card VT6655 on the roboard we need first do install a linux 2.6.30 version, we can do this by copying the Linux-Image-2.6.30-vortex86mx deb file to the roboard and then install.

After burning the pendrive  instead copying the image 2.6.34.1 version to the root directory of the pendrive, copy the 2.6.30, and follow the rest of the roboard installation.

If your roboard is already installed, just copy the image.deb file to a roboard folder and then, inside the same folder, do

# cd /usr/src

# dpkg -i image.deb

# update-initramfs -k 2.6.30-vortex86mx -c

# update-grub

Reboot the system now and then restart with the 2.6.30 version linux

Use “apt-get remove” to uninstall other version of kernel that might interfere on boot

(3) Copying the needed material to install the card

Download the following link files to you computer and place them on a roboard folder, in our case /usr/src/

config

VT6655-Drivers or Download from VIA site

linux-2.6.30-kernel

(4) Compiling and Installing the 2.6.30 kernel

Decompress the linux 2.6.30 kernel.

# tar -xf linux-2.6.30-vortex86mx.tar.bz2

This might take a long time.

# cd /usr/src/linux-2.6.30

# cp ../config-2.6.30-vortex86mx-apm .config

# make modules_prepare

# rmdir –ignore-fail-on-non-empty /lib/modules/2.6.30-vortex86mx-apm/build

Check if the directory still in there, with the winspc, if it still exists delete it

Now create a link to the folder
# ln -sf /usr/src/linux-2.6.30 /lib/modules/2.6.30-vortex86mx/build


(5) Compiling and Installing the VT6655 driver

# unrar /usr/src/VT6655_Linux_src_v1.20.02_x86.rar

# cd VT6655_Linux_src_v1.20.02_x86/driver

# cp vntconfiguration.dat /etc

# make && make install

Reboot

(5) Testing the card

After booting, look for the card in the boot

# dmesg | grep via

[    6.783647] eth1 (viawget): not using net_device_ops yet

To test the card, for example try just to lookup for avaliable wireless networks, put on terminal

# iwlist ethX scan

Where ethX is your ethernet wireless and the return is looked like

To configure your network we can also give some hints.

Using wpa supplicant method, edit the /etc/network/interfaces file and add another ethernet interface, your wireless interface, for example like this

# This file describes the network interfaces available on your system

# and how to activate them. For more information, see interfaces(5).
# The loopback network interface

auto lo

iface lo inet loopback
# The primary network interface

auto eth0

allow-hotplug eth0

#iface eth0 inet dhcp

iface eth0 inet static

address 192.168.0.252

gateway 192.168.0.1

netmask 255.255.255.0

network 192.168.0.0

brodcast 192.168.0.255

# the wireless interface 1

auto eth1

allow-hotplug eth1

iface eth1 inet dhcp

wpa-conf /usr/src/wpa_supplicant.conf

Where our device is configured as dhcp and the configuration file wpa_supplicant.conf is in the folder /usr/src.

Now you can look at http://linux.die.net/man/5/wpa_supplicant.conf to see how to build your network access configuration file.

Enjoy

Advertisements

10 Responses to “Installing wireless VT6655 on roboard”

  1. Chris Paton Says:

    Hi there, would this work for Ubuntu 9.0.4? how do you get access to the roboard while the wireless card is plugged in? or is the card not plugged in till later?

    Thank you
    Chris

    • robomarinheiro Says:

      Hi Chris
      Well, about Ubuntu i cannot say for sure these steps will work.
      To access Roboard i’m using a ssh shell. Right after you install the debian on the roboard, edit
      /etc/network/interfaces
      and change the dhcp to static and set a fixed IP, like this

      # The primary network interface
      auto eth0
      allow-hotplug eth0
      #iface eth0 inet dhcp
      iface eth0 inet static
      address 192.168.0.252
      gateway 192.168.0.1
      netmask 255.255.255.0
      network 192.168.0.0
      brodcast 192.168.0.255

      then you connect a crossover ethernet cable between the roboard ethernet and an extra ethernet port on your PC and set the port with a fix IP of
      192.168.0.1
      Download Putty and WinSCP and connect to the roboard fixed IP, on this case 192.168.0.252.
      Insert the user name and password that you have placed when the instalation and thats it!

      Now you can remove the VGA card and work with the roboard.

  2. Chris Paton Says:

    Still having issues… part 5,

    cp vntconfiguration.dat /etc$ make && make install

    isnt working, the make, ive moved the ‘vntconfiguration.dat’ to the /etc folder but cant do anything with it.

    thanks
    chris

    • robomarinheiro Says:

      Hi Chris
      Thanks for the comments.

      In first place, those are two separated command lines.
      1st, cp thevntconfiguration. dat /etc
      2nd, do make && make install.
      If this still give error like no rule to make, try to redo
      # rmdir –ignore-fail-on-non-empty /lib/modules/2.6.30-vortex86mx-apm/build
      This time, again make sure and check if the directory still there, with the winspc (via ssh), if it still exists delete it using winscp.
      After this folder desapear create a link to the folder
      # ln -sf /usr/src/linux-2.6.30 /lib/modules/2.6.30-vortex86mx/build

      Hope this solve your problem,
      Anything else please leave comment.

  3. Chris Paton Says:

    seems to be looking for the .config file in:

    /lib/modules/2.6.34.1-vortex86-sg/build/.config

    and its not there! in 2.6.30.

    • Chris Paton Says:

      when i run the make && make install

    • robomarinheiro Says:

      well, at first thought, i can see 2 reasons so that happen.

      First, the folder /lib/modules/2.6.34.1-vortex86-sg/build/ that you need to delete before creating the link, its not being deleted by the command.
      have you try to delete it with the WinSCP? Have you check if it stills there even after you delete it?
      do
      #ls /usr/src/linux-2.6.30 /lib/modules/2.6.30-vortex86mx/build
      just to check if its deleted or not, if not you really need to get it erased, i did it using WinSCP as i suggested before.

      Second, did you forget to copy the config file in step four?
      # cp ../config-2.6.30-vortex86mx-apm .config

      Check these two and see if it helps

      • Chris Paton Says:

        thanks for all your help 🙂

        yeah it has been copied over

        but 2.6.34 wont be allowed to be deleted so moved to desktop. when i run make && make install its still looking for the .config in /lib/modules/2.6.34.1-vortex86-sg/build/.config

      • robomarinheiro Says:

        To do this you should be logged as ROOT.
        And you have to make sure that the .config file is in the folder
        and you MUST also delete the folder to create the link to a NEW one.

  4. Chris paton Says:

    Can’t seem to get working on ubuntu, gonna switch to debian. Will let you know how it goes. Thank you

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: